UK Bank Disruption

Incident Report for Yaspa

Resolved

This incident has been resolved.
Posted Aug 17, 2026 - 10:59 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 17, 2026 - 10:52 UTC

Identified

Overview of the issue
- As of Monday, 17 August - 11:00GMT, Yaspa has experienced service disruption with some UK Banks.
- Most end-users appear to be affected.

What Yaspa is doing
- The Yaspa team is currently working to resolve the problem with the affected third parties. During this time, you may temporarily see lower rates of conversion for payments.

What you need to do
- There is no further action required.

For further information
- Yaspa's status page is here: https://yaspa.statuspage.io/

If you have any questions, please speak to your Yaspa Customer Success Manager.
Posted Aug 17, 2026 - 10:32 UTC
This incident affected: Yaspa Platform, Yaspa Test Platform, and Yaspa UK Banks.